Skip to content

Upgrading camera 0.10 to 0.11

Breaking0.10.6 → 0.11.4Breaking1Platform6New2Fixed4Other7

BreakingUpgrade verdict

1 breaking change and 6 platform requirement changes.

  • On Android, the camera plugin now uses a different underlying implementation that works on more devices. It does everything the old one did except for a few limitations listed in the README.
  • The package now requires Flutter 3.35 and Dart 3.9 or newer.
  • You now need Flutter 3.35.0 or newer, which includes Dart 3.9, to use this version.
  • You need at least Flutter 3.29 and Dart 3.7 to use this version.
Top 4 of 7 that need code or config changes

Dart SDK requirement changed in 0.11.3: ^3.2.3 → ^3.9.0.

Flutter requirement changed in 0.11.3: >=3.16.6 → >=3.35.0.

Breaking1
Changes the Android implementation from camera_android to camera_android_camerax, which has better support for a wider range of devices.
camera_androidcamera_android_camerax
Platform6
Updates minimum supported SDK version to Flutter 3.35/Dart 3.9.
Updates minimum supported SDK version to Flutter 3.35.0/Dart 3.9.
Updates minimum supported SDK version to Flutter 3.29/Dart 3.7.
Updates minimum supported SDK version to Flutter 3.27/Dart 3.6.
Updates minimum supported SDK version to Flutter 3.19/Dart 3.3.
Updates minimum supported SDK version to Flutter 3.16/Dart 3.2.