Upgrading camera 0.11 to 0.12
Breaking0.11.4 → 0.12.2Platform3New3Changed1Fixed1
BreakingUpgrade verdict
3 platform requirement changes.
In plain terms
- The package now requires Flutter 3.41 or newer and Dart 3.11 or newer.
- The package now requires a newer Flutter and Dart version, so older projects must upgrade before using it.
- You now need Flutter 3.38 or newer, which includes Dart 3.10 or newer, to use this package.
Must act 3 items need code or config changes
Dart SDK requirement changed in 0.12.1: ^3.9.0 → ^3.12.0.
Flutter requirement changed in 0.12.1: >=3.35.0 → >=3.44.0.
What you must change
Platform3
Updates minimum supported SDK version to Flutter 3.41/Dart 3.11.
Updates minimum supported SDK version to Flutter 3.44/Dart 3.12.
Updates minimum supported SDK version to Flutter 3.38/Dart 3.10.