Upgrading camera 0.9 to 0.10
Breaking0.9.8+1 → 0.10.6Breaking5Platform5Deprecated1New6Changed11Fixed4Other3
BreakingUpgrade verdict
4 breaking changes and 5 platform requirement changes.
In plain terms
- Removes obsolete null checks on non-nullable values.
- Remove usage of deprecated quiver Optional type.
- Removes usage of _ambiguate method in example.
- Breaking Change Bumps default camera_android package version, which updates permission exception code from cameraPermission to CameraAccessDenied and AudioAccessDenied.
Must act Top 5 of 10 that need code or config changes
Dart SDK requirement changed in 0.10.6: >=2.14.0 <3.0.0 → ^3.2.3.
Flutter requirement changed in 0.10.6: >=2.8.0 → >=3.16.6.
What you must change
Breaking4
Removes obsolete null checks on non-nullable values.
Remove usage of deprecated quiver Optional type.
Removes usage of _ambiguate method in example.
_ambiguateBreaking Change Bumps default camera_android package version, which updates permission exception code from cameraPermission to CameraAccessDenied and AudioAccessDenied.
cameraPermissionCameraAccessDeniedAudioAccessDeniedPlatform5
Updates minimum supported SDK version to Flutter 3.13/Dart 3.1.
Updates support matrix in README to indicate that iOS 11 is no longer supported.
Clients on Flutter versions that still support iOS 11 can keep using the package with iOS 11 but will not receive further iOS implementation updates.
Updates minimum supported SDK version to Flutter 3.10/Dart 3.0.
Updates minimum supported SDK version to Flutter 3.7/Dart 2.19.
Deprecations to plan for
Deprecated1
Migrates styleFrom usage in examples off of deprecated primary and onPrimary parameters.
styleFromprimaryonPrimary