Upgrading signet 0.19 to 0.20
Breaking0.19.0 → 0.20.0Platform2
BreakingUpgrade verdict
2 platform requirement changes.
In plain terms
- This version needs Ruby 3.0 or newer to install and run.
- This version needs Ruby 3.1 or newer to install and run.
Must act 2 items need code or config changes
Ruby requirement changed in 0.20.0: >= 2.7 → >= 3.1.
What you must change
Platform2
Updates the minimum required Ruby version to 3.0.
Updates the required Ruby version to 3.1.