Upgrading pyasn1-modules 0.3 to 0.4
Breaking0.3.0 → 0.4.2Breaking1Platform2Changed1
BreakingUpgrade verdict
1 breaking change and 2 platform requirement changes.
In plain terms
- The package no longer runs on Python 2.7, 3.6 or 3.7, which are no longer maintained.
- The package now works with Python 3.13.
- The package now works on newer Python versions 3.11 and 3.12.
Must act 3 items need code or config changes
Python requirement changed in 0.4.0: !=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*,!=3.5.*,>=2.7 → >=3.8.
What you must change
Breaking1
Removes support for end-of-life Python 2.7, 3.6 and 3.7.
Platform2
Adds support for Python 3.13.
Adds support for Python 3.11 and 3.12.