Skip to content

Upgrading url_launcher 4 to 5

Breaking4.2.0+3 → 5.7.10Breaking2Platform4Deprecated1New5Changed11Fixed8Other16

BreakingUpgrade verdict

2 breaking changes and 4 platform requirement changes.

  • Android apps can no longer rely on the plugin's fallback dependency handling.
  • Android apps that use this plugin must switch from the old Android Support Library to AndroidX. Apps already on AndroidX should see no functional changes.
  • The Android build now compiles against Android SDK version 29.
  • You must upgrade Flutter to at least 1.12.13+hotfix.5 to use this version.
Top 5 of 7 that need code or config changes

url_launcher publishes an official migration guide for version 5. It covers more than the release notes do.

Also migrate ↗

Dart SDK requirement changed in 5.4.7: >=2.0.0-dev.28.0 <3.0.0 → >=2.1.0 <3.0.0.

Flutter requirement changed in 5.4.5: >=0.5.6 <2.0.0 → >=1.12.13+hotfix.5 <2.0.0.

Breaking2
Removes the Android dependencies fallback.
Migrates from the deprecated Android Support Library to AndroidX, requiring Android apps using the plugin to also migrate.
Platform4
Updates the Android compileSdkVersion to 29.
compileSdkVersion
Requires Flutter SDK 1.12.13+hotfix.5 or greater.
Re-lands embedder v2 support with corrected Flutter SDK constraints.
Bumps the minimum Flutter version to 1.5.0.
Deprecated1
Keeps handling deprecated Android v1 embedding classes for backward compatibility.