Skip to content

Upgrading url_launcher 3 to 4

Breaking3.0.3 → 4.2.0+3Breaking5Platform1New3Changed1Fixed3Other2

BreakingUpgrade verdict

5 breaking changes and a platform requirement change.

  • You must now set statusBarBrightness yourself instead of relying on a default.
  • This version undoes the 4.2.0 release because that release broke compatibility but was only given a minor version bump. If you already moved your app to AndroidX, go to 5.0.0, which is the correctly versioned release of the same changes.
  • This version accidentally included a breaking change in what should have been a minor update. It was undone in version 4.2.0+3.
  • The plugin now uses AndroidX instead of the old Android Support Library. Android apps that still use the old support library must migrate to AndroidX too.
Top 4 of 6 that need code or config changes

Flutter requirement changed in 4.0.0: >=0.1.4 <2.0.0 → >=0.5.6 <2.0.0.

Breaking5
statusBarBrightness no longer has a default value.
statusBarBrightness
Reverts the breaking 4.2.0 update; users who already migrated to AndroidX should update to 5.0.0 instead.
Marks the 4.2.0 release as a bad breaking change published on a minor version upgrade, reverted by 4.2.0+3.
Migrates from the deprecated Android Support Library to AndroidX, requiring Android apps using the plugin to also migrate.
Updates launch to return Future<bool>.
launchFuture<bool>
Platform1
Now requires a minimum Flutter version of 0.5.6.