Skip to content

Upgrading html 0.14 to 0.15

Breaking0.14.0+4 → 0.15.7Breaking2Security1Platform3New1Changed4Fixed7Other6

BreakingUpgrade verdict

2 breaking changes and 3 platform requirement changes and a security fix.

  • Three fields on the HTML parser class are removed. They were always empty, so nothing should have depended on them.
  • The package now uses Dart's null safety, so code that uses it must also be null safe.
  • You need Dart 3.6 or newer to use this version.
  • This version needs a newer Dart SDK, version 3.2 or above.
Top 5 of 6 that need code or config changes

Dart SDK requirement changed in 0.15.7: >=2.3.0 <3.0.0 → ^3.6.0.

Breaking2
Drops the lastPhase, beforeRcDataPhase, and container fields from HtmlParser.
HtmlParser.lastPhaseHtmlParser.beforeRcDataPhaseHtmlParser.containerHtmlParser
Migrates the package to null safety.
Security1
Fixes an XSS vulnerability in htmlToCodeMarkup() by escaping DOCTYPE, element, and attribute names.
htmlToCodeMarkup()
Platform3
Requires Dart 3.6.
Requires Dart 3.2 or later.
Requires Dart 2.19.