Skip to content

Upgrading html 0.13 to 0.14

Breaking0.13.4+2 → 0.14.0+4Breaking2Changed2Fixed2

BreakingUpgrade verdict

2 breaking changes.

  • The package can now only read and write text in UTF-8 or ASCII, so files in other character encodings are no longer supported.
  • A helper library for running the parser from the console has been removed, so code importing it will no longer compile.
2 items need code or config changes

Dart SDK requirement changed in 0.14.0+3: >=2.0.0 <3.0.0 → >=2.3.0 <3.0.0.

Drops utf.

Breaking2
Drops support for encodings other than UTF-8 and ASCII.
Removes the parser_console.dart library.
parser_console.dart