Upgrading hop 0.21 to 0.22
Breaking0.21.0 → 0.22.2Breaking1Deprecated1New1Changed3
BreakingUpgrade verdict
1 breaking change.
In plain terms
- The enable-type-checks option no longer exists on the analyzer task helper, so any use of it must be deleted.
- The createDart2JsTask helper is deprecated and should be replaced.
Must act 2 items need code or config changes
Dart SDK requirement changed in 0.22.2: >=0.4.7+1 → >=0.5.11+1.
Moves bot >=0.20.0 → >=0.20.1, bot_io >=0.20.0 → >=0.21.1, pathos >=0.4.7+1 → >=0.5.3. Your build may pick other versions.
What you must change
Breaking1
Removes the unsupported enable-type-checks option from createDartAnalyzerTask.
createDartAnalyzerTaskenable-type-checksDeprecations to plan for
Deprecated1
Deprecates createDart2JsTask.
createDart2JsTask