Upgrading hop 0.20 to 0.21
Breaking0.20.0+1 → 0.21.0Breaking1Changed1
BreakingUpgrade verdict
1 breaking change.
In plain terms
- Some old, deprecated parts of the package have been removed, so code using them may stop working.
Must act 1 item needs code or config changes
Dart SDK requirement changed in 0.21.0-dev: >=0.4.5+1.r21094 → >=0.4.7+1.
Moves args >=0.4.5+1 → >=0.4.7+1, bot >=0.16.3 → >=0.20.0, bot_io >=0.20.0-dev → >=0.20.0, logging >=0.4.5+1 → >=0.4.7+1, meta >=0.4.5+1 → >=0.4.7+1, pathos >=0.4.5+1 → >=0.4.7+1, unittest >=0.4.5+1 → >=0.4.7+1. Your build may pick other versions.
What you must change
Breaking1
Removes deprecated APIs, though the notes do not specify which ones.