Skip to content

Upgrading fixnum 0.10 to 1

Breaking0.10.11 → 1.1.1Breaking1Platform2New1Changed2Fixed1Other4

BreakingUpgrade verdict

1 breaking change and 2 platform requirement changes.

  • The package now uses Dart's null safety. Code that opts in may fail to compile where it previously failed at runtime; code that has not opted in behaves as before.
  • This version needs Dart 3.1.0 or newer.
  • The package now requires Dart SDK 2.19 or newer.
3 items need code or config changes

Dart SDK requirement changed in 1.1.1: >=2.1.1 <3.0.0 → ^3.1.0.

Breaking1
Migrates the package to null safety, turning some runtime errors into static errors for opted-in users.
Platform2
Requires Dart ^3.1.0.
Updates the minimum SDK constraint to 2.19.