Upgrading rubocop 0.64 to 0.65
Breaking0.64.0 → 0.65.0Platform1New1Changed1Fixed5Other1
BreakingUpgrade verdict
A platform requirement change.
In plain terms
- Drop support for Ruby 2.2.0 and 2.2.1.
Must act 1 item needs code or config changes
Ruby requirement changed in 0.65.0: >= 2.2.0 → >= 2.2.2.
What you must change
Platform1
Drop support for Ruby 2.2.0 and 2.2.1.
API changes
Generated by DepDelta from published Ruby source. Not mixed with prose notes.
- added:
module YAMLDuplicationChecker - added:
static method PathUtil.chdir(_) - added:
static method YAMLDuplicationChecker.check(_, _)
- added:
class BreakNode < Node - added:
class RetryNode < Node - added:
method BreakNode.arguments() - added:
method DefinedNode.node_parts() - added:
method Node.range_type?() - added:
method RetryNode.arguments()
- added:
method ExpectOffense.expect_no_corrections()