Upgrading pry 0.13 to 0.14
Breaking0.13.1 → 0.14.2Breaking2Platform3New2Fixed10
BreakingUpgrade verdict
2 breaking changes and 3 platform requirement changes.
In plain terms
- Pry no longer runs on Ruby 1.9 or JRuby versions older than 9.0.
- Pry no longer loads plugins automatically. You must require each plugin yourself in your pryrc file or list it in your Gemfile.
- Pry now works with Ruby 3.2.
- Pry now works with Ruby 3.1.
Must act 5 items need code or config changes
Ruby requirement changed in 0.14.2: >= 1.9.3 → >= 2.0.
What you must change
Breaking2
Removes support for Ruby 1.9 and JRuby < 9.0.
Removes support for plugin autoloading; plugins must now be required from pryrc or added to the Gemfile.
requirepryrcGemfilePlatform3
Adds support for Ruby 3.2.
Adds support for Ruby 3.1.
Adds support for Ruby 3.0.