Skip to content

Upgrading hashie 4 to 5

Breaking4.1.0 → 5.2.0Breaking1Platform3New14Changed6Fixed18Other30

BreakingUpgrade verdict

1 breaking change and 3 platform requirement changes.

  • Reverts the deep_merge_new_hash hook from #619 in favor of the breaking-change proposal in #632, which preserves incoming hash subclasses directly.
  • Adds support for Ruby 4.0.
  • Drops Ruby 2.7 support, raises the minimum to Ruby 3.0, and removes obsolete Ruby version gates and symbol-conversion fallbacks.
  • Requires Ruby 2.7 or later and upgrades Rubocop to 1.82.0.
4 items need code or config changes

Ruby requirement changed in 5.2.0: >= 0 → >= 3.0.

Breaking1
Reverts the deep_merge_new_hash hook from #619 in favor of the breaking-change proposal in #632, which preserves incoming hash subclasses directly.
deep_merge_new_hash
Platform3
Adds support for Ruby 4.0.
Drops Ruby 2.7 support, raises the minimum to Ruby 3.0, and removes obsolete Ruby version gates and symbol-conversion fallbacks.
Requires Ruby 2.7 or later and upgrades Rubocop to 1.82.0.
Rubocop