Upgrading googleauth 0.17 to 1
Breaking0.17.1 → 1.17.7Security1Platform1Deprecated2New8Changed3Fixed21Other6
Fetching 39 releases from GitHub…24 / 39
SecurityIncludes a security warning in ExternalAccount and ImpersonatedServiceAccount credentials.#551 ↗
BreakingUpgrade verdict
A platform requirement change and a security fix.
In plain terms
- This version requires Ruby 3.0 or newer.
- These credential types now surface a security warning to users.
- A helper method used to build credentials is now marked as deprecated and may be removed in a future release.
- When setting up a sign-in callback address, you should now pass it by name rather than by position. The old way still works but is discouraged.
Must act 4 items need code or config changes
Ruby requirement changed in 1.17.2: >= 2.5 → >= 3.2.
Adds google-cloud-env ~> 2.2, google-logging-utils ~> 0.1, pstore ~> 0.1.
Drops memoist, multi_json.
Moves faraday >= 0.17.3, < 2.0 → >= 1.0, < 3.a, jwt >= 1.4, < 3.0 → >= 1.4, < 4.0, signet ~> 0.15 → >= 0.16, < 2.a. Your build may pick other versions.
What you must change
Security1
Includes a security warning in ExternalAccount and ImpersonatedServiceAccount credentials.
ExternalAccountImpersonatedServiceAccountPlatform1
Updates the minimum Ruby version to 3.0.
Deprecations to plan for
Deprecated2
Deprecates the make_creds method in DefaultCredentials.
DefaultCredentialsmake_credsDeprecates the positional argument for callback_uri and introduces a keyword argument instead.
callback_uri