Upgrading google-cloud-env 1 to 2
Breaking1.6.0 → 2.4.1Platform4New7Fixed6Other3
BreakingUpgrade verdict
4 platform requirement changes.
In plain terms
- This version needs Ruby 3.2 or newer, and it also works with the upcoming Ruby 4.0.
- This version of the library now needs Ruby 3.1 or newer to run.
- This version no longer works on Ruby older than 3.0, so users must upgrade their Ruby runtime.
- This version no longer works on Ruby 2.6, so users on that version must upgrade Ruby before upgrading the gem.
Must act Top 3 of 4 that need code or config changes
Ruby requirement changed in 2.4.0: >= 2.5 → >= 3.2.
What you must change
Platform4
Requires Ruby 3.2 minimum and adds support for Ruby 4.0.
Updates the required Ruby version to 3.1.
Requires Ruby 3.0 or later.
Drops support for Ruby 2.6.