Upgrading google-apis-core 0.18 to 1
Breaking0.18.0 → 1.4.0Breaking1Security1Platform1New2Changed2Fixed8Other1
BreakingUpgrade verdict
1 breaking change and a platform requirement change and a security fix.
In plain terms
- The gem now uses a different HTTP library under the hood. Most apps won't notice, but apps that rely on the old library's interfaces will need to adjust.
- This version needs Ruby 3.2 or a later version to run.
- Adds checks that stop file paths from escaping their intended location when commands are run.
Must act 3 items need code or config changes
Ruby requirement changed in 1.2.0: >= 3.1 → >= 3.2.
Adds faraday ~> 2.13, faraday-follow_redirects ~> 0.3, multi_json ~> 1.11.
Drops httpclient, mutex_m.
Moves addressable ~> 2.5, >= 2.5.1 → ~> 2.9, googleauth ~> 1.9 → ~> 1.14, mini_mime ~> 1.0 → ~> 1.1, retriable >= 2.0, < 4.a → >= 3.1, < 5.0. Your build may pick other versions.
What you must change
Breaking1
Replaces the underlying httpclient library with Faraday, which may break applications that depend on httpclient interfaces.
Security1
Implements path validation and traversal checks in HttpCommand.
HttpCommandPlatform1
Requires Ruby 3.2 or newer.