Upgrading google-apis-core 0.16 to 0.17
Breaking0.16.0 → 0.17.0Platform1Fixed2
BreakingUpgrade verdict
A platform requirement change.
In plain terms
- This version needs at least Ruby 3.1, and Ruby 3.4 is the default.
Must act 1 item needs code or config changes
Ruby requirement changed in 0.17.0: >= 2.7 → >= 3.1.
What you must change
Platform1
Requires Ruby 3.1 minimum and defaults to Ruby 3.4.