Upgrading typer 0.23 to 0.24
Breaking0.23.2 → 0.24.2Platform1Deprecated1Changed8Fixed1Other77
BreakingUpgrade verdict
A platform requirement change.
In plain terms
- This version no longer works on Python 3.9, so you need a newer Python to use it.
- The separate typer-slim and typer-cli packages are discontinued. Install and use the typer package instead.
Must act 2 items need code or config changes
Python requirement changed in 0.24.0: >=3.9 → >=3.10.
What you must change
Platform1
Drops support for Python 3.9.
Deprecations to plan for
Deprecated1
Drops support for typer-slim and typer-cli; no more versions will be released, use only typer.
typer-slimtyper-clityper