Upgrading starlette 0.19 to 0.20
Breaking0.19.1 → 0.20.4Platform1New1Fixed8
BreakingUpgrade verdict
A platform requirement change.
In plain terms
- This version no longer runs on Python 3.6, so users on that version must upgrade Python before upgrading Starlette.
Must act 1 item needs code or config changes
Python requirement changed in 0.20.0: >=3.6 → >=3.7.
What you must change
Platform1
Drops support for Python 3.6.