Upgrading six 0.9 to 1
Breaking0.9.2 → 1.17.0Breaking1Changed1
Fetching 26 releases from GitHub…1 / 26
BreakingUpgrade verdict
1 breaking change.
In plain terms
- On Python 3.14 and newer, the old URL opener classes are no longer available through six's urllib.request compatibility layer.
Must act 1 item needs code or config changes
Requires Python !=3.0.*,!=3.1.*,!=3.2.*,>=2.7 from 1.17.0 (none stated before).
What you must change
Breaking1
Removes URLopener and FancyURLopener classes from urllib.request on Python 3.14 or greater.
URLopenerFancyURLopenerurllib.request