Skip to content

Upgrading pydata-sphinx-theme 0.14 to 0.15

Breaking0.14.4 → 0.15.4Breaking1Platform1Deprecated1New6Changed22Fixed49Other65

BreakingUpgrade verdict

1 breaking change and a platform requirement change.

  • Removes deprecated configs and associated code and tests.
  • The package no longer supports Python 3.8; you need Python 3.9 or newer.
  • Deprecates the pygments related variable to correct typos.
3 items need code or config changes

Python requirement changed in 0.15.0rc0: >=3.8 → >=3.9.

Breaking1
Removes deprecated configs and associated code and tests.
Platform1
Bumps minimum Python from 3.8 to 3.9 and adds 3.12 to CIs.
Deprecated1
Deprecates the pygments related variable to correct typos.