Upgrading jsii 0.22 to 1
Breaking0.22.0 → 1.142.0Breaking6Platform4New29Changed8Fixed80Other22
Fetching 162 releases from GitHub…46 / 162
BreakingUpgrade verdict
6 breaking changes and 4 platform requirement changes.
In plain terms
- Python 3.9 is no longer supported.
- CI matrix: baseline Python changed from 3.9 to 3.10, removed dedicated Python 3.9 test entry.
- Generated code: python_requires bumped from ~=3.9 to ~=3.10, pyright pythonVersion set to 3.10.
- Runtime: pyright and black target versions updated.
Must act Top 5 of 10 that need code or config changes
Python requirement changed in 1.133.0: >=3.6 → >=3.10.
Adds publication >=0.0.3, typeguard ==2.13.3.
Installs 8 packages in all (was 6).
What you must change
Breaking6
Python 3.9 is no longer supported.
CI matrix: baseline Python changed from 3.9 to 3.10, removed dedicated Python 3.9 test entry.
Generated code: python_requires bumped from ~=3.9 to ~=3.10, pyright pythonVersion set to 3.10.
Runtime: pyright and black target versions updated.
Snapshots updated to reflect new version constraints.
pacmak: jsii-pacmak now has a peer dependency on jsii-rosetta.
Platform4
Raises the minimum required Go version to 1.26.
python: require Python 3.10+ in modules and update runtime dependencies.
Dev dependencies: mypy bumped to 2.1.0 (requires Python >= 3.10).
Drop Python 3.9 support, require Python >= 3.10.