Upgrading jmespath 0.10 to 1
Breaking0.10.0 → 1.1.0Platform2Fixed1
Fetching 3 releases from GitHub…1 / 3
BreakingUpgrade verdict
2 platform requirement changes.
In plain terms
- The library can now be installed and used on newer Python versions, 3.12 to 3.14.
- The library no longer works on Python 3.7 or 3.8, so users on those versions must upgrade Python.
Must act 2 items need code or config changes
Python requirement changed in 1.1.0: >=2.6, !=3.0.*, !=3.1.*, !=3.2.* → >=3.9.
What you must change
Platform2
Adds support for Python 3.12 through 3.14.
Removes support for Python 3.7 and 3.8.