Upgrading fastapi-pagination 0.14 to 0.15
Breaking0.14.3 → 0.15.16Platform1Deprecated2New11Changed8Fixed9
BreakingUpgrade verdict
A platform requirement change.
In plain terms
- This version no longer works on Python 3.9, so users on 3.9 must upgrade their Python version.
- Five optional integrations are now deprecated and may be removed in a future release.
- Using this package with outdated pydantic or FastAPI versions now triggers a deprecation warning.
Must act 3 items need code or config changes
Python requirement changed in 0.15.1: <4.0,>=3.9 → >=3.10.
What you must change
Platform1
Drops Python 3.9 support.
Deprecations to plan for
Deprecated2
Deprecates the bunnet, databases, gino, odmantic, and orm extensions.
bunnetdatabasesginoodmanticormAdds deprecation warnings for old
pydantic and FastAPI versions.pydanticFastAPI