Upgrading cloudpickle 0.8 to 1
Breaking0.8.1 → 1.6.0Platform2New7Changed4Fixed15Other1
BreakingUpgrade verdict
2 platform requirement changes.
In plain terms
- This version of cloudpickle no longer works on Python versions older than 3.5.
- This release brings back partial compatibility with the older Python 3.4 so long-term-support projects can still get bug fixes.
Must act 2 items need code or config changes
Requires Python >=3.5 from 1.4.0 (none stated before).
What you must change
Platform2
Requires Python 3.5 or later.
Restores partial support for Python 3.4 for downstream projects with LTS versions that would benefit from cloudpickle bug fixes.