Upgrading Werkzeug 0.14 to 0.15
Safe0.14.1 → 0.15.6Security2Fixed1
SecurityHigh · CVSS 7.5Pallets Werkzeug vulnerable to Path TraversalGHSA-j544-7q9p-6xp8 · CVE-2019-14322 ↗
SafeUpgrade verdict
2 security fixes. Nothing to change in your code.
In plain terms
- Pallets Werkzeug vulnerable to Path Traversal
- Pallets Werkzeug before 0.15.3, when used with Docker, has insufficient debugger PIN randomness because Docker containers share the same machine id.
Must act 2 items need code or config changes
Requires Python >=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.* from 0.15.0 (none stated before).
What you must change
Security2
Pallets Werkzeug vulnerable to Path Traversal
High · CVSS 7.5Pallets Werkzeug before 0.15.3, when used with Docker, has insufficient debugger PIN randomness because Docker containers share the same machine id.