Skip to content

Upgrading Mako 0.9 to 1

Unknown0.9.1 → 1.4.3Security4

UnknownUpgrade verdict

DepDelta hasn't looked for this range's notes yet, so breaking changes can't be ruled out.

  • DepDelta hasn't finished looking for the notes in this range, so it can't rule out breaking changes yet.
Top 3 of 4 that need code or config changes

Requires Python >=3.10 from 1.4.0 (none stated before).

Adds markupsafe >=2.0.

Installs 1 package in all (was 0).

Security4
Mako: Path traversal via drive-letter URI on Windows in TemplateLookup
Medium · CVSS 6.5
Mako vulnerable to path traversal via backslash URI on Windows in TemplateLookup
Mako is a template library written in Python. Prior to 1.3.11, TemplateLookup.get_template() is vulnerable to path traversal when a URI starts with // (e.g., //../../../secret.txt). The root cause is an inconsistency between two slash-stripping implementations. Any file readable by the process can be returned as rendered template content when an application passes untrusted input directly to TemplateLookup.get_template(). This vulnerability is fixed in 1.3.11.
High · CVSS 7.5
Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.