Upgrading web 0.5 to 1
Breaking0.5.1 → 1.1.2Breaking1Platform2Deprecated3New8Changed3Fixed4Other3
BreakingUpgrade verdict
1 breaking change and 2 platform requirement changes.
In plain terms
- Some APIs now return double instead of num, which can break code that relied on num.
- You need Dart 3.13.0 or newer to use this version of the package.
- You need Dart 3.4.0 or newer to use this version.
- A helper for reading a node's text is deprecated; use the standard textContent property instead.
Must act Top 5 of 6 that need code or config changes
Dart SDK requirement changed in 1.1.2: ^3.3.0 → ^3.13.0.
What you must change
Breaking1
APIs returning a double value now return
double instead of num.doublenumPlatform2
Requires Dart
^3.13.0 to support library-level dart fix migrations.Requires Dart
^3.4.0.Deprecations to plan for
Deprecated3
Deprecates the Node.text extension in favor of Node.textContent.
Node.textNode.textContentDeprecates the [] extensions on Storage.
Storage[]Deprecates TouchListWrapper and TouchListConvert in favor of JSImmutableListWrapper.
TouchListWrapperTouchListConvertJSImmutableListWrapper