Upgrading web 0.3 to 0.4
Unknown0.3.0 → 0.4.2Deprecated4New1Changed2Fixed1Other2
UnknownUpgrade verdict
DepDelta hasn't looked for the notes of 2 of 4 releases yet, so breaking changes can't be ruled out.
In plain terms
- DepDelta hasn't finished looking for the notes in this range, so it can't rule out breaking changes yet.
Must act Top 3 of 4 that need code or config changes
Dart SDK requirement changed in 0.4.1: >=3.2.0-194.0.dev <4.0.0 → ^3.2.0.
Deprecations to plan for
Deprecated4
Undeprecates some APIs and the helpers library that were deprecated in 0.4.1, since deprecations are breaking in Flutter.
Deprecates the helpers.dart library in favor of web.dart.
helpers.dartweb.dartDeprecates NodeGlue.append in favor of Node.appendChild.
NodeGlue.appendNode.appendChildDeprecates NodeGlue.clone in favor of Node.cloneNode.
NodeGlue.cloneNode.cloneNode