Upgrading watcher 0.9 to 1
Breaking0.9.7+15 → 1.2.1Platform4New4Changed6Fixed18Other3
BreakingUpgrade verdict
4 platform requirement changes.
In plain terms
- This version needs Dart SDK 3.4.0 or newer.
- You need Dart 3.1.0 or newer to use this version.
- This version needs Dart 3.4 or newer, so older Dart SDKs can no longer use it.
- You need a newer Dart SDK to use this version.
Must act Top 3 of 4 that need code or config changes
Dart SDK requirement changed in 1.2.0: >=2.2.0 <3.0.0 → ^3.4.0.
What you must change
Platform4
Requires Dart SDK ^3.4.0.
Requires Dart SDK ^3.1.0.
Requires Dart 3.4.
Requires Dart SDK 2.12 or later.