Upgrading stack_trace 0.9 to 1
Breaking0.9.3+2 → 1.12.2Breaking2Platform8Deprecated1New15Changed24Fixed36Other10
BreakingUpgrade verdict
2 breaking changes and 8 platform requirement changes.
In plain terms
- Code can no longer extend or implement the Dependency class.
- The environment field on Pubspec can no longer be null, so code reading it must handle a value instead of null.
- You need Dart 3.4 or newer to use this version.
- You need Dart 2.18 or newer to use this version.
Must act Top 5 of 11 that need code or config changes
Dart SDK requirement changed in 1.12.0: >=1.0.0 <2.0.0 → ^3.4.0.
What you must change
Breaking2
Seals the
Dependency class.DependencyMakes
Pubspec.environment non-nullable.Pubspec.environmentPlatform8
Requires Dart 3.4 or greater.
Requires Dart 2.18 or greater.
Updates the minimum SDK to 1.23.0.
Requires Dart 3.8.
Requires Dart 3.6.
Requires Dart 3.2.
Requires Dart SDK
^3.1.0.Requires Dart 3.4.
Deprecations to plan for
Deprecated1
Deprecates
Chain.track in favor of Zone.errorCallback for attaching stack chains to all errors.Zone.errorCallbackChain.track