Upgrading source_gen_test 0.1 to 1
Breaking0.1.1+4 → 1.4.2Breaking1Platform1New2Changed31Fixed2Other3
BreakingUpgrade verdict
1 breaking change and a platform requirement change.
In plain terms
- The package now uses Dart's null safety feature, so code that uses it must also be null safe.
- You need Dart version 2.12.0 or newer to use this package.
Must act 2 items need code or config changes
Dart SDK requirement changed in 1.4.0: >=2.10.0 <3.0.0 → ^3.12.0.
What you must change
Breaking1
Migrates the package to null safety.
Platform1
Requires Dart 2.12.0.