Upgrading source_gen 0.7 to 0.8
Breaking0.7.6 → 0.8.3+1Breaking1New1Changed8Fixed3
BreakingUpgrade verdict
1 breaking change.
In plain terms
- If your code still passes the old requireLibraryDirective option when creating a PartBuilder, it will no longer compile.
Must act 1 item needs code or config changes
Dart SDK requirement changed in 0.8.3+1: >=2.0.0-dev.19.0 <2.0.0 → >=2.0.0-dev.19.0 <3.0.0.
What you must change
Breaking1
Removes the deprecated requireLibraryDirective parameter from PartBuilder.
PartBuilderrequireLibraryDirective