Skip to content

Upgrading source_gen 0.3 to 0.4

Breaking0.3.0+2 → 0.4.8Breaking1Platform1New7Changed8Fixed2Other2

BreakingUpgrade verdict

1 breaking change and a platform requirement change.

  • The tool no longer reads the inside of functions when analyzing code. This makes it much faster, but anything that relied on seeing function bodies may stop working.
  • This version needs Dart SDK 1.12 or newer.
2 items need code or config changes

Dart SDK requirement changed in 0.4.5: >=1.9.0 <2.0.0 → >=1.12.0 <2.0.0.

Breaking1
Analysis no longer parses function bodies, greatly speeding up generation but potentially breaking usages that need function bodies.
Platform1
Requires Dart 1.12.