Skip to content

Upgrading pubspec_parse 0.1 to 1

Breaking0.1.8 → 1.7.0Breaking3Platform5Deprecated1New11Changed4Fixed5Other5

BreakingUpgrade verdict

3 breaking changes and 5 platform requirement changes.

  • Code can no longer extend or implement the Dependency class.
  • The environment field on Pubspec can no longer be null, so code handling a null value must be updated.
  • The package now requires Dart's null-safety feature, so code using it must be null-safe.
  • You need Dart 3.8 or newer to use this version.
Top 5 of 9 that need code or config changes

Dart SDK requirement changed in 1.6.0: >=2.7.0 <3.0.0 → ^3.8.0.

Breaking3
Seals the Dependency class.
Dependency
Makes Pubspec.environment non-nullable.
Pubspec.environment
Migrates the package to null safety.
Platform5
Requires Dart 3.8.
Requires Dart 3.6.
Requires Dart 3.2.
Requires Dart 3.0.
Requires Dart SDK >= 2.18.0.
Deprecated1
Deprecates both the author and authors fields in the pubspec.
authorauthors