Upgrading pubspec 0.0 to 0.1
Breaking0.0.15 → 0.1.5Breaking1New3Changed2
BreakingUpgrade verdict
1 breaking change.
In plain terms
- Packages that use pubspec can now be compiled natively, because pubspec no longer pulls in a library that only works with the Dart VM.
Must act 1 item needs code or config changes
Dart SDK requirement changed in 0.1.2: >=1.9.0 <2.0.0 → >=2.2.2 <3.0.0.
Adds uri ^0.11.3+1.
Drops stuff, yamlicious.
What you must change
Breaking1
Removes the dependency on the stuff package, which had a mirrors dependency that prevented native compilation of packages depending on pubspec.
Json_utils.dart