Upgrading pana 0.20 to 0.21
Breaking0.20.1 → 0.21.45Breaking1Fixed4Other1
Fetching 47 releases from GitHub…3 / 47
BreakingUpgrade verdict
1 breaking change.
In plain terms
- The use of kind in pub-data.json is deprecated, as it may contain different value on different dartdoc version.
Must act 1 item needs code or config changes
Dart SDK requirement changed in 0.21.33: >=2.12.0 <3.0.0 → >=3.0.0 <4.0.0.
Adds crypto ^3.0.0, lints ^3.0.0, string_scanner ^1.1.0, test ^1.5.2.
Drops quiver.
Moves analyzer >=1.0.0 <3.0.0 → >=5.0.0 <7.0.0, cli_util ^0.3.0 → ^0.4.0, http ^0.13.0 → ^1.0.0, json_annotation ^4.0.0 → ^4.8.1, markdown ^4.0.0 → ^7.0.0, pubspec_parse ^1.0.0 → ^1.2.2, tar ^0.4.0 → ^1.0.0. Your build may pick other versions.
What you must change
Breaking1
The use of kind in pub-data.json is deprecated, as it may contain different value on different dartdoc version.
kindpub-data.jsondartdoc