Upgrading pana 0.17 to 0.18
Unknown0.17.1 → 0.18.2
DepDelta is still reading the notes for this range, so breaking changes can't be ruled out yet.
- DepDelta is still reading the release notes in this range, so it can't rule out breaking changes yet.
- This page updates as the notes come in.
DepDelta is still reading the release notes in this range. This updates as they come in.
Dart SDK requirement changed in 0.18.0: >=2.10.0 <3.0.0 → >=2.12.0 <3.0.0.
Adds collection ^1.15.0.
Moves analyzer >=0.41.0 <2.0.0 → ^1.0.0, args >=1.6.0 <3.0.0 → ^2.0.0, async >=1.13.3 <3.0.0 → ^2.0.0, cli_util >=0.2.0 <0.4.0 → ^0.3.0, html >=0.13.3 <0.16.0 → ^0.15.0, http >=0.11.3 <0.14.0 → ^0.13.0, io >=0.3.4 <2.0.0 → ^1.0.0, json_annotation >=2.0.0 <5.0.0 → ^4.0.0, logging >=0.11.3+1 <2.0.0 → ^1.0.0, markdown >=3.0.0 <5.0.0 → ^4.0.0, meta ^1.1.7 → ^1.4.0, pub_semver >=1.4.0 <3.0.0 → ^2.0.0, pubspec_parse >=0.1.4 <2.0.0 → ^1.0.0, quiver >=0.24.0 <4.0.0 → ^3.0.0, tar ^0.3.0 → ^0.4.0 and 1 more. Your build may pick other versions.