Skip to content

Upgrading package_info_plus 4 to 5

Breaking4.2.0 → 5.0.1Breaking1Platform1Changed1

BreakingUpgrade verdict

1 breaking change and a platform requirement change.

  • On the web, the version JSON URL no longer needs to end in a file extension like .json.
  • You must upgrade to Dart 3.2.0 or newer and Flutter 3.6.0 or newer to use this version.
2 items need code or config changes

Dart SDK requirement changed in 5.0.1: >=2.18.0 <4.0.0 → ^3.2.0.

Flutter requirement changed in 5.0.1: >=3.3.0 → >=3.6.0.

Adds web >=0.3.0 <0.5.0.

Breaking1
Fixes versionJsonUrl on web to allow URLs without a page extension.
versionJsonUrl
Platform1
Raises minimum Dart to 3.2.0 and minimum Flutter to 3.6.0 to support pkg:web.