Upgrading package_info_plus 0.6 to 1
Breaking0.6.4 → 1.4.3+1Breaking2New1Changed4Fixed11Other9
BreakingUpgrade verdict
2 breaking changes.
In plain terms
- A deprecated helper for older Flutter embedding is gone, so code that still calls it will no longer compile.
- The package now uses Dart's null safety, so apps must be null-safe to use it.
Must act 2 items need code or config changes
Dart SDK requirement changed in 1.0.1: >=2.1.0 <3.0.0 → >=2.12.0 <3.0.0.
What you must change
Breaking2
Removes the deprecated embeddingV1 function.
embeddingV1Migrates the package to null safety.
API changes
Generated by DepDelta from published Dart source. Not mixed with prose notes.
- removed:
static set PackageInfo.disablePackageInfoPlatformOverride(bool override) - changed:
ctor PackageInfo({ this.appName, this.packageName, this.version, this.buildNumber, }) → ctor PackageInfo({ required this.appName, required this.packageName, required this.version, required this.buildNumber, this.buildSignature = …, }) - changed:
static method PackageInfo.setMockInitialValues({ @required String appName, @required String packageName, @required String version, @required String buildNumber, }): void → static method PackageInfo.setMockInitialValues({ required String appName, required String packageName, required String version, required String buildNumber, required String buildSignature, }): void - added:
field PackageInfo.buildSignature: final String