Upgrading mocktail 0.3 to 1
Review needed0.3.0 → 1.0.5Changed3Other13
Review neededUpgrade verdict
3 behavior changes.
In plain terms
- The package now accepts a newer version of a library it depends on.
- The library no longer requires the test package to be installed.
- The Fake class now relies on the test_api package instead of the test package.
Must act Nothing to change
No breaking, platform, security or deprecated items in this range.
Dart SDK requirement changed in 1.0.0-dev.0: >=2.12.0 <3.0.0 → >=2.12.0 <4.0.0.
Adds test_api >=0.2.1 <0.8.0.
Drops test.
Moves matcher ^0.12.10 → ^0.12.15. Your build may pick other versions.
Nothing in this upgrade needs a code or configuration change.