Upgrading meta 0.12 to 1
Breaking0.12.1 → 1.19.0Breaking2Deprecated3New13Changed8Other2
Fetching 44 releases from GitHub…10 / 44
BreakingUpgrade verdict
2 breaking changes.
In plain terms
- The @ResourceIdentifier annotation has a new name, @RecordUse, so existing code using the old name must be updated.
- Some public functions and methods now use the general Object type instead of private types in their signatures.
- The generic directive target is deprecated; use the more specific targets instead.
- The Required class and the required annotation are now deprecated and should be avoided in new code.
Must act 5 items need code or config changes
Dart SDK requirement changed in 1.17.0: >=1.12.0 <2.0.0 → ^3.5.0.
What you must change
Breaking2
Renames @ResourceIdentifier to @RecordUse.
@ResourceIdentifier@RecordUseChanges private types in public API signatures to Object.
ObjectDeprecations to plan for
Deprecated3
Deprecates TargetKind.directive in favor of the new TargetKinds and TargetKind.library.
TargetKind.directiveTargetKind.libraryMarks Required and required as @Deprecated.
Requiredrequired@DeprecatedIndicates that @required and @Required are set to be deprecated for later removal.
@required@Required