Upgrading matcher 0.11 to 0.12
Breaking0.11.4+6 → 0.12.20Breaking4Platform5Deprecated2New11Changed16Fixed7Other11
BreakingUpgrade verdict
4 breaking changes and 5 platform requirement changes.
In plain terms
- Expand bounds on test_api dependency to allow the next breaking release which will remove the cyclic dependency on this package.
- Removed FailureHandler, DefaultFailureHandler, configureExpectFailureHandler, and getOrCreateExpectFailureHandler.
- Removed the name parameter for isInstanceOf.
- Potentially breaking bug fix.
Must act Top 5 of 11 that need code or config changes
Dart SDK requirement changed in 0.12.20: >=1.0.0 <2.0.0 → ^3.10.0.
Adds async ^2.10.0, meta ^1.8.0, stack_trace ^1.10.0, term_glyph ^1.2.0, test_api >=0.5.0 <0.8.0.
What you must change
Breaking4
Expand bounds on test_api dependency to allow the next breaking release which will remove the cyclic dependency on this package.
test_apiRemoved FailureHandler, DefaultFailureHandler, configureExpectFailureHandler, and getOrCreateExpectFailureHandler.
FailureHandlerDefaultFailureHandlerconfigureExpectFailureHandlergetOrCreateExpectFailureHandlerexpectunittestRemoved the name parameter for isInstanceOf.
nameisInstanceOfPotentially breaking bug fix.
greaterThanPlatform5
Requires Dart 3.7.
Requires Dart 3.4.
Requires Dart 3.0.
Require Dart 2.17 or greater.
Update minimum Dart SDK to 2.2.0.
Deprecations to plan for
Deprecated2
Deprecate isCyclicInitializationError and NullThrownError.
isCyclicInitializationErrorNullThrownErrorDeprecated the isInstanceOf class.
isInstanceOfTypeMatcher