Upgrading mason_logger 0.2 to 0.3
Breaking0.2.16 → 0.3.6Platform1New1Changed3Fixed3Other2
BreakingUpgrade verdict
A platform requirement change.
In plain terms
- You now need Dart 3.5.0 or newer to use this package.
Must act 1 item needs code or config changes
Dart SDK requirement changed in 0.3.6: >=3.3.0 <4.0.0 → >=3.10.0 <4.0.0.
Moves ffi ^2.1.0 → ^2.1.3, win32 ^5.4.0 → ^6.3.0. Your build may pick other versions.
What you must change
Platform1
Tightens dependency constraints and raises the minimum Dart SDK to 3.5.0.
API changes
Generated by DepDelta from published Dart source. Not mixed with prose notes.
- changed:
ctor ProgressAnimation({this.frames = …}) → ctor ProgressAnimation({ this.frames = …, this.interval = …, }) - added:
field ProgressAnimation.interval: final Duration