Upgrading latlong2 0.8 to 0.9
Breaking0.8.2 → 0.9.1Breaking1Platform1Changed1Fixed1
BreakingUpgrade verdict
1 breaking change and a platform requirement change.
In plain terms
- The methods for changing a point's latitude or longitude after creation are gone.
- Projects must use Dart 3.0 or newer to depend on this version.
Must act 2 items need code or config changes
Dart SDK requirement changed in 0.9.0: >=2.12.0 <4.0.0 → >=3.0.0 <4.0.0.
What you must change
Breaking1
Removes
setLatitude() and setLongitude().setLatitude()setLongitude()Platform1
Bumps the minimum Dart version to 3.0.