Skip to content

Upgrading io 0.3 to 1

Breaking0.3.5 → 1.1.0Breaking2Platform1New1Changed1Other1

Fetching 6 releases from GitHub…2 / 6
BreakingUpgrade verdict

2 breaking changes and a platform requirement change.

  • Creating a SharedStdIn now requires passing a stream; the class was previously marked for testing only, so this is treated as non-breaking.
  • AnsiCode and AnsiCodeType can no longer be extended or implemented; they were already closed to extension via private constructors.
  • This version needs Dart 3.4 or newer, so older Dart SDKs can no longer use it.
3 items need code or config changes

Dart SDK requirement changed in 1.0.5: >=2.1.0 <3.0.0 → ^3.4.0.

Breaking2
Makes the stream parameter required for SharedStdIn.new.
SharedStdIn.new
Marks AnsiCode and AnsiCodeType as final, preventing subclassing and interface use.
AnsiCodeAnsiCodeType
Platform1
Requires Dart 3.4.