Upgrading grpc 0.4 to 0.5
Breaking0.4.1 → 0.5.0Breaking1New1Other1
BreakingUpgrade verdict
1 breaking change.
In plain terms
- This version only works with Dart 2, so projects still on Dart 1 cannot use it.
Must act 1 item needs code or config changes
Dart SDK requirement changed in 0.5.0: >=1.24.3 <2.0.0 → >=2.0.0-dev.58.0 <2.0.0.
What you must change
Breaking1
The package now exclusively supports Dart 2.
API changes
Generated by DepDelta from published Dart source. Not mixed with prose notes.
- changed:
ctor Server(List<Service> services) → ctor Server(List<Service> services, [List<Interceptor> interceptors = …]) - changed:
ctor ServerHandler(this._serviceLookup, this._stream) → ctor ServerHandler(this._serviceLookup, this._stream, [this._interceptors = …]) - added:
typedef Interceptor = GrpcError Function( ServiceCall call, ServiceMethod method)