Upgrading geolocator 8 to 9
Breaking8.2.1 → 9.0.2Platform1New1Changed3Other1
BreakingUpgrade verdict
A platform requirement change.
In plain terms
- Android apps using this package must build against Android SDK 33.
Must act 1 item needs code or config changes
Dart SDK requirement changed in 9.0.1: >=2.12.0 <3.0.0 → >=2.15.0 <3.0.0.
Flutter requirement changed in 9.0.1: >=1.20.0 → >=2.8.0.
Moves geolocator_android ^3.1.0 → ^4.1.3. Your build may pick other versions.
What you must change
Platform1
Requires compileSdkVersion 33 in android/app/build.gradle when updating to version 9.0.0.
compileSdkVersion